Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые...

0 голосов
71 просмотров

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов.

программа: Pascal ABC.


Информатика (81 баллов) | 71 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const
  n = 25;
var
  a: array[1..n] of integer;
  i, s: integer;
begin
  Writeln('Введите элементы массива');
  s := 0;
  for i := 1 to n do
  begin Read(a[i]); s := s + a[i] end;
  Writeln('Среднее значение элементов массива равно ', s/n)
end.

(142k баллов)
0

У Вас в самом начале написано: "const
n = 25;", на уроках мы обычно не пишем такое, это обязательно писать здесь?

0

Это как Вам угодно. Можете вычеркнуть вообще и заменить по тексту n на 25. Можете перенести в var и потом после begin присвоить значение. Но с const - это правильный вариант, потому что если вдруг не 25 элементов, достаточно поменять только там.

0

Спасибо огромное.

0

Пожалуйста.

0 голосов

Var A:array[1..25] of Integer;
i:integer;
S:real;
begin
Readln(N);
For i:=1 to 25 do
Readln(A[i]);
For i:=1 to 25 do
S:=S+A[i];
S:=S/25;
Writeln(S);
end.

(1.6k баллов)
0

Очень мило, жаль только массив не описан.

0

забыл, спасибо)

0

А еще вопрос: зачем Вы N вводите, если у Вас циклы до 25?