Входные данные некоторый программы записаны в текстовый файл. В каждой строке файла...

0 голосов
35 просмотров

Входные данные некоторый программы записаны в текстовый файл. В каждой строке файла содержится два целых и три вещественных числа, разделенные пробелами. Напишите программу, которая выводит на экран сумму целых и сумму вещественных чисел из каждой строки.


Информатика (45 баллов) | 35 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  f:Text;
  i,j:integer;
  a,b,c:real;
begin
  Assign(f,'MyFile.txt');
  Reset(f);
  while not eof(f) do begin
    Read(f,i,j); Readln(f,a,b,c);
    Writeln(i+j,' ',a+b+c)
  end;
  Close(f)
end.

(142k баллов)