Написать программу, объясните. Ввести двухзначное число. Если сумма цифр числа четная,...

0 голосов
1.2k просмотров

Написать программу, объясните.
Ввести двухзначное число. Если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2.


Информатика (5.3k баллов) | 1.2k просмотров
Дан 1 ответ
0 голосов
var a: integer;
begin
    write('Введите число: ');
    read(a);
    if odd(a mod 10 + a div 10) then a := a - 2
                                               else a := a + 2;
    write(a)
end.
(13.3k баллов)