Решите в тетради задачи, используя цикл while-wend 1. Написать программу, вычисляющую...

0 голосов
81 просмотров

Решите в тетради задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).


Информатика (117 баллов) | 81 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

using System;

namespace Interesting {
    class Program {
        static void Main() {
            float Max = 0;
            float Sum = 0;
            float N = 0;
            string s;
            float num;

            Console.WriteLine("Введите последовательность чисел. Для окончания введите пустую строку");
            try {
                while (true) {
                    Console.WriteLine("Введите число");
                    s = Console.ReadLine();
                    num = Convert.ToSingle(s);
                    Max = (num > Max) ? num : Max;
                    Sum += num;
                    N++;
                }
            }
            catch (Exception e) {
                Console.WriteLine("Ввод закончен");
            }

            Console.WriteLine("Максимальное = {0}, Среднее = {1}", Max, Sum / N);
        }
    }
}

(53.1k баллов)