Написать программу ** языке Паскаль для вычисления суммы s=2+4+8+16+32+64+128+256+512...

0 голосов
28 просмотров

Написать программу на языке Паскаль для вычисления суммы s=2+4+8+16+32+64+128+256+512 использовать формулу подсчета суммы геометрической прогрессии


Информатика (14 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

begin

 var (b, q, n) := (2, 2, 9);

 var S := b * (1 - q ** n) / (1 - q);

 Write($'Сумма первых {n} членов: S = {S}')

end.

(2.5k баллов)