Помогите пожалуйста срочно решить! 1)Написать программу ** паскале:Вычислить длину орбиты...

0 голосов
44 просмотров

Помогите пожалуйста срочно решить!
1)Написать программу на паскале:Вычислить длину орбиты земли.Радиус орбиты Земли равен 150 млн.км.
2)Написать программу на паскале:Прием на работу идёт на конкурсной основе.Условия приема требуют 20 лет трудового стажа и возраста не более 45 лет.Определить,будет ли человек принят на работу.
3))Написать программу на паскале:Вывести на экран все трехзначные числа ,сумма квадратов цифр которых равна 105.


Информатика (40 баллов) | 44 просмотров
0

Не знаю, кто захочет решать задание, положив набок голову...

0

Я надеюсь кто нибудь,да захочет)

0

Надейтесь дальше

0

Да уж.... приношу извинения, какой-то сбой. этот комментарий был совсем к другой задаче, где приложение на 90 градусов повернуто. У Вас все нормально. Придется мне Вам задание решить в плане компенсации за незаслуженный "наезд" ))

0

Какая версия Паскаля нужна?

0

Ах,вон вы о чём,а я подумал о том,что уже ночь и склонив голову на бок в полу сне никто не захочет решать)PascalABC.NET

0

Отлично, там как раз Pi - предопределенная константа

0

Хорошо,тогда жду вас,заранее скажу спасибо.

Дан 1 ответ
0 голосов
Правильный ответ

Program P1;
const
  R=150000000;
begin
  Writeln('Длина орбиты Земли составляет ',2*Pi*R:0:0,' км.')
end.

Результат выполнения программы:
Длина орбиты Земли составляет 942477796 км.

program p2;
var
  stazh,vozrast:integer;
begin
  Write('Введите через пробел стаж и возраст: ');
  Readln(stazh,vozrast);
  if (stazh>=20) and (vozrast<=45) then Writeln('Принимается')<br>  else Writeln('Не принимается')
end.

Тестовое решение:
Введите через пробел стаж и возраст: 23 50
Не принимается

program p3;
var
  i,j,k:integer;
begin
  for i:=1 to 9 do
    for j:=0 to 9 do
      for k:=0 to 9 do
        if sqr(i)+sqr(j)+sqr(k)=105
        then Write(i,j,k,' ')
end.
   
Результат выполнения программы:
458 485 548 584 845 854

(142k баллов)
0

Спасибо большое вам и у меня ещё маленький вопрос в Access как сделать запрос выборку и написать после 01.01.2006?

0

Недопустимо в комментариях обсуждать вопросы не относящиеся к заданию. Для этого есть Личные Сообщения