!Даю 100 баллов! Помогите пожалуйста! Напишите программу в Python 2.7 или 3.3 По данному...

0 голосов
79 просмотров

!Даю 100 баллов! Помогите пожалуйста!
Напишите программу в Python 2.7 или 3.3
По данному числу N выведите все целые степени двойки, не превосходящие N, в порядке возрастания.
!Операцией возведения в степень пользоваться нельзя!
Входные данные:
Вводится натуральное число
Выходные данные:
Выведите ответ на задачу
Пример
Входные данные:
50
Выходные данные:
1 2 4 8 16 32


Информатика (158 баллов) | 79 просмотров
Дан 1 ответ
0 голосов

Var n,st:integer; begin write('n = '); readln(n); st:=1; while st<=n do begin write(st,' '); st:=st*2; end; writeln; end. Пример: n = 50 1 2 4 8 16 32

(14 баллов)