Помогите напишите задачу и ее решение в паскале. Массивы Составить программу для решения...

0 голосов
34 просмотров

Помогите напишите задачу и ее решение в паскале.

Массивы
Составить программу для решения следующей задачи:
Дан массив целых чисел. Выяснить какой элемент массива больше, k-й или p-й.


Информатика (20 баллов) | 34 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c:integer;
n:array [1..10] of integer;
begin
writeln('введите номера элементов для сравнения');
readln(a,b);
randomize;{скажите что посмотрели эту функцию в интернете и она нужна для подготовки программы к применению функции рандом}
for c:=1 to 10 do begin
n[c]:=random(-20,20);{так мы в массив ставим случайное число в диапазоне от -20 до 20}
writeln(n[c]);
end;
if n[a]else writeln('меньший элемент массива под номером ' ,b,' больший элемент массива под номером ' ,a);
end.

(8.6k баллов)