Даны целые числа a и b.Написать программу, которая подсчитывает, сколько среди них...

0 голосов
115 просмотров

Даны целые числа a и b.Написать программу, которая подсчитывает, сколько среди них меньших нуля


Информатика (19 баллов) | 115 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

var

a,b:integer;

k:byte; 

begin

write ('A = ');readln(a);

write ('B = ');readln(b);

if (a<0) and (b<0) then k:=2 else</p>

if ((a<0) and (b>0)) or ((a>0) and (b<0)) then k:=1 else k:=0;</p>

writeln (k);

readln;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

(2.8k баллов)
0 голосов

uses crt;
var a,b,c:integer;
begin
a:=-1; b:=-2; c:=0;
if (a < 0 ) then inc(c);
if (b < 0 ) then inc(c);
writeln('sredi nih ',c,' menshe 0');
readln;
end.

 

так?  если что в лс

(1.6k баллов)