Помогите напишите задачу и ее решение в паскале. Составить программу для решения...

0 голосов
48 просмотров

Помогите напишите задачу и ее решение в паскале.

Составить программу для решения следующей задачи:
Гражданин 1 марта открыл счет в банке, вложив 1000 руб. Через каждый месяц размер вклада увеличивается на 2% от имеющейся суммы. Определить за какой месяц величина ежемесячного увеличения вклада превысит 30 руб.


Информатика (20 баллов) | 48 просмотров
0

var sum, growth: real; months: integer;begin sum := 1000; months := 0; repeat months := months + 1; growth := sum * 0.02; sum := sum + growth; until growth > 30; writeln('Сумма - ', sum); writeln('Месяцев прошло - ', months); writeln('Номер месяца в году - ', (3 + months - 1) mod 12 + 1);end.

Дан 1 ответ
0 голосов
Правильный ответ

Var d:integer;
c,a:real;
begin
a:=1000;
d:=0;
while a <=1030 do begin<br>c:=a/100*2;
a:=a+c;
d:=d+1;
end;
writeln('величина ежемесячного увеличения вклада превысит 30 руб за ',d,' месяца');
end.

(8.6k баллов)
0

вы не так поняли. сами 2% должны быть больше 30