Написать программу, которая для первых n натуральных чисел находит сумму чётных и...

0 голосов
65 просмотров

Написать программу, которая для первых n натуральных чисел находит сумму чётных и произведение нечётных чисел. число n вводится с клавиатуры . выполнить программу для n=13 , записать результат


Информатика (48 баллов) | 65 просмотров
Дан 1 ответ
0 голосов

Const n=13;
var i,s,p:integer;
begin
s:=0; p:=1;
for i:=1 to n do begin
if (i mod 2 = 0) then s:=s+i;
if (i mod 2 <> 0) then p:=p*i;
end;
writeln("Сумма четных = ",s," , произведение нечетных =",p);
end.

(367 баллов)