ПОЖАЛУЙСТА ПОМОГИТЕ, КОМУ НЕТРУДНО!!! СТАВЛЮ МНОГО БАЛЛОВ!! Напишите программу, которая...

0 голосов
58 просмотров

ПОЖАЛУЙСТА ПОМОГИТЕ, КОМУ НЕТРУДНО!!! СТАВЛЮ МНОГО БАЛЛОВ!!
Напишите программу, которая во введённой символьной строке заменяет все буквы а на буквы б и наоборот. Заглавные на заглавные, строчные на строчные.


Информатика (304 баллов) | 58 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

PascalABC.Net

var
  str : string;
  i : integer;
begin
  write('Введите строку: ');
  readln(str);
  
  for i := 1 to length(str) do
    case str[i] of
      'а' : str[i] := 'б';
      'А' : str[i] := 'Б';
      'б' : str[i] := 'а';
      'Б' : str[i] := 'А';
    end;
 
  writeln(str);  
end.

(918 баллов)
0

спасибо, работает :)

0

Пожалуйста =)