Напишите программу, выводящую ** экран изображение шахматной доски, где чёрные клетки...

0 голосов
945 просмотров

Напишите программу, выводящую на экран изображение шахматной доски, где чёрные клетки изображаются звёздочками, а белые — пробелами. Рекомендуемый вид экрана после выполнения программы представлен ниже:


image

Информатика (83 баллов) | 945 просмотров
0

А для чего ее писать?

0

Мы из ума должны взять?

0

Паскаль

Дан 1 ответ
0 голосов
Правильный ответ

Const
  s1='*  *  *  *  ';
  s2='  *  *  *  *';
var
  i:integer;
begin
  for i:=1 to 4 do Writeln(s1,#13#10,s2)
end.

Результат выполнения программы:
*  *  *  * 
  *  *  *  *
*  *  *  * 
  *  *  *  *
*  *  *  * 
  *  *  *  *
*  *  *  * 
  *  *  *  *


(142k баллов)
0

Скажи пожалуйста, что означают # между цифрами 13 и 10?

0

В языке Паскаль так записываются символы при помощи их десятичного кода в таблице ASCII. В данном случае это коды символов "перевод строки" и "возврат каретки" - последовательность, которая эквивалентна отдельному оператору Writeln; с пустым списком: она делает то же самое - вызывает переход к новой строке вывода.

0

Спасибо большое.

0

Иначе бы пришлось писать так: for i:=1 to 4 do begin Writeln(s1); Writeln; Writeln(s2) end;

0

Пожалуйста

0

Согласитесь, использование #13#10 делает эффективнее и нагляднее общий код программы.

0

Можно было также написать Writeln(s1+#13#10+s2);

0

Спасибо