Помогите написать программу по информатике по задаче! Пожалуйста! проверьте является ли...

0 голосов
48 просмотров

Помогите написать программу по информатике по задаче! Пожалуйста!
проверьте является ли шестизначный номер билета счастливым (сумма первых трёх цифр ровна сумме последних трёх цифр) надо через поскали как то (((
НА ФОТО 3 ЗАДАЧА


image

Информатика (12 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Var
x,a,b: integer;
begin
read(x);
a := x div 100000;
x := x mod 100000;
a := a + (x div 10000);
x := x mod 10000;
a := a + (x div 1000);
x := x mod 1000;
b := x div 100;
x := x mod 100;
b := b + (x div 10);
x := x mod 10;
b := b + x;
if a = b then
write('Билетик счастливый!')
else ('Билетик не счастливый');
end.

(1.1k баллов)
0

спасибо большое но можно как не будь с обьяснением

0

тут единственное объяснение – это работа с операторами mod и div. mod - это остаток от делителя (при целочисленном делении), а div – число, проучившееся при целочисленном делении