Написать программу для Паскаль через оператор Case. Для целого числа K от 1 до 99...

0 голосов
60 просмотров

Написать программу для Паскаль через оператор Case.

Для целого числа K от 1 до 99 напечаать фразу "мне K лет", учитывая при этом что при вводе некоторых значений K слово "лет" надо заменить на слово "год" или "года".


Информатика (70 баллов) | 60 просмотров
0

Советую поискать тут, на Сервисе: эту задачу я решал на прошлой неделе.

Дан 1 ответ
0 голосов

Program p1;
Var a:integer;
Begin
  Write('Введите возраст: ');
  Readln(a);
  Case a of
    11..14:Write('Мне ',a,' лет');
    else
    Case a mod 10 of
      1:Write('Мне ',a,' год');
      2..4:Write('Мне ',a,' года');
      else Write('Мне ',a,' лет');
    End;
  End;
End.

(728 баллов)