Составить программу для паскальабс.нет. КОЛИЧЕСТВО ЧИСЕЛ НЕ КРАТНЫХ ПЯТИ В УКАЗАННОМ...

0 голосов
53 просмотров

Составить программу для паскальабс.нет.

КОЛИЧЕСТВО ЧИСЕЛ НЕ КРАТНЫХ ПЯТИ В УКАЗАННОМ ДИАПАЗОНЕ


Информатика (54 баллов) | 53 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program vasha_zadacha_1;
var a,b,c:integer ; 
begin 
c:=0; 
writeln('введите промежуток от'); 
readln(a); 
writeln('до'); 
readln(b); 
if a>b then  
for b:=b to a do begin 
if (b mod 5<>0) then c:=c+1;   
end; 
for a:=a to b do begin   
if (a mod 5<>0) then c:=c+1; 
 end; 
writeln('колличество чисел не кратных пяти в этом диапазоне ', c); 
end.

(8.6k баллов)
0 голосов

Var i, a, b, count, crat:integer;
begin
readln(a, b);
for i:=a to b do
begin
crat:=i mod 5;
if crat <> 0 then
begin
count:=count+1
end;
end;
writeln('Количество не кратных = ', count);
end.

(309 баллов)