Paskal выдаёт ошибку, помогите пожалуйста испрвить: Задача:Написать программу, которая...

0 голосов
74 просмотров

Paskal выдаёт ошибку, помогите пожалуйста испрвить:
Задача:Написать программу, которая проверяет, является ли четным введенное пользователем целое число.
program cisla;
var
a:integer;
begin
writeln('Введите число, ');
readln(a);
if a mod 2=0 then writeln('Число четное');
else
writeln('Число нечетное');
readln
end.


Информатика (347 баллов) | 74 просмотров
0

Почему не указали, где именно ошибка и какое сообщение?

0

потому что ошибка тут очевидна, она не логическая, а чисто синтаксическая.

0

Да я вижу, что перед else ;

0

И компилятор её сразу указывает.. Но может у человека еще что-то выдается, мало ли...

0

да нет, тут все верно:)

0

нет, всё нормально)спасибо. я просто немного ступила

Дан 1 ответ
0 голосов

Перед "else" не нужна точка я запятой;)

(1.1k баллов)