Помогите пожалуйста очень очень срочно нужно Написать программу в Паскаль...

0 голосов
50 просмотров

Помогите пожалуйста очень очень срочно нужно Написать программу в Паскаль r=(max(min(x,y),z))/3


Информатика (80 баллов) | 50 просмотров
0

С пользовательскими функциями или баз?

0

Нужно простой разветвляющийся алгоритм для чайников.

Дан 1 ответ
0 голосов
Правильный ответ

Var
  r,x,y,z,min,max:real;
begin
  Write('Введите x,y,z: '); Read(x,y,z);
  if x  if z>min then max:=z else max:=min;
  r:=max/3;
  Writeln('r=',r)
end.

Тестовое решение:
Введите x,y,z: 18.4 9.62 10.7
r=3.56666666666667

(142k баллов)
0

Спасибо вам большое!

0

пожалуйста