КТО РЕШИТ , ТОМУ 70 БАЛЛОВ!! составить программу нахождения суммы чисел , кратных 3 в...

0 голосов
68 просмотров

КТО РЕШИТ , ТОМУ 70 БАЛЛОВ!! составить программу нахождения суммы чисел , кратных 3 в массиве М [1:12] (числа вводятся с клавиатуры)


Информатика (97 баллов) | 68 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Const
  n=12;
var
  M:array[1..n] of integer;
  i,s:integer;
begin
  Writeln('Введите ',n,' элементов массива');
  s:=0;
  for i := 1 to n do
  begin Read(M[i]); if M[i] mod 3=0 then s:=s+M[i] end;
  Writeln('Сумма элементов, кратных трем, равна ',s)
end.

Тестовое решение:
Введите 12 элементов массива
32 18 40 52 8 14 28 35 18 21 11 41
Сумма элементов, кратных трем, равна 57

(142k баллов)
0 голосов

Program enot_peredelani;
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
writeln('введите элемент массива');
for c:= 1 to 12 do
begin
readln(a[c]);
if a[c] mod 3 = 0 then 
d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.

(8.6k баллов)
0

всё работает как надо, я проерял

0

проверял

0

хотя можно чуток узменить

0

Program enot;
Var a: array[1..100] of integer;
c,d:integer;
begin
d:=0;
for c:= 1 to 12 do begin
writeln('введите элемент массива');
readln(a[c]);
if a[c] mod 3 = 0 then d:=a[c]+d;
end;
writeln('сумма чисел кратных 3 ==> ',d);
end.

0

Еще раз вынесете в комментарии текст программы - начнете копить баллы предупреждений

0

без проблем