Напишите программу, которая вводит натуральное число и находит все числа ** отрезке [0,...

0 голосов
252 просмотров

Напишите программу, которая вводит натуральное число и находит все числа на отрезке [0, N], сумма цифр которых не меняется при умножении числа на 2,3,4,5,6,7,8 и 9 (например, число 9). Используйте функцию для вычисления суммы цифр числа. ПАСКАЛЬ СРОЧНО ПОМОГИТЕ


Информатика (17 баллов) | 252 просмотров
0

Это и есть задание?

0

Да

0

Я так и не понял что нужно сделать то -_-

0

Написать функцию для этой задачи

0

Входные данныеВходная строка содержит два натуральных числа – границы диапазона a и b . Гарантируется, что a ≤ b .Выходные данныеПрограмма должна вывести все числа, удовлетворяющий условию, в одной строке, разделив их пробелами.Примерывходные данные1 10выходные данные9

0

ага, интересная задачка. если никто не решит, то может вечером решу

Дан 1 ответ
0 голосов
Правильный ответ

Var
    n, i, aon_i, k: integer;
    f: boolean;

function AmountOfNumbers(n: integer): integer;
var
    s: integer;
begin
    s := 0;
    while n > 0 do
    begin
        s := s + n mod 10;
        n := n div 10;
    end;
    AmountOfNumbers := s;
end;

begin
    readln(n);
   
    for i := 0 to n do
    begin
        f := true;
        aon_i := AmountOfNumbers(i);
       
        for k := 2 to 9 do
            f := f and (aon_i = AmountOfNumbers(k * i));
        if f then writeln(i);
    end;
end.

(53.1k баллов)