Напишите программу, которая выводит ** экран все цифры числа начиная с первой. (**...

0 голосов
96 просмотров

Напишите программу, которая выводит на экран все цифры числа начиная с первой. (на Паскале)


Информатика (29 баллов) | 96 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var    str, i, m:integer;
n: string;
a: array[1..10] of integer;
begin
write('Введите число: ');
readln(str);
if str < 0 then str := -str; // удаляем знак числа
n := IntToStr(str); // преобразуем число в массив
m := length(n); // считаем элементы массива
for i := 1 to m do writeln(n[i]); // выводим элементы (цифры) числа
end.

(2.3k баллов)