Написать программу Пользователь вводит 5 целых чисел,программа находит сумму всех...

0 голосов
47 просмотров

Написать программу
Пользователь вводит 5 целых чисел,программа находит сумму всех отрицательных и произведение всех положительных чисел


Информатика (108 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Uses CRT;
var i,s,p,a,n:integer;
begin
  
p:=1; 
  write('введите кол-во чисел ');
  readln(n);
  for i:=1 to n do begin
                            
write('введите ',i,'число: ');
                            readln(a);
                            if a<0 then s:=s+a<br>                            else p:=p*a
                          end;
 
writeln('сумма отрицательных чисел равна: ',s);
 writeln('произведение всех положительных чисел равно: ',p)
end.
как-то так)

(1.6k баллов)