Написать программу, которая выведет 4 первые четных числа(2,4,6,8) и написать программу...

0 голосов
39 просмотров

Написать программу, которая выведет 4 первые четных числа(2,4,6,8) и написать программу которая находит сумму этих чисел.


Информатика (14 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

У меня вот так вышло, хотя можно еще несколькими способами сделать эту задачу

int main()
{
int mass[10]; //оглашаем массив из 10 целых чисел(или сколько захотите сами)

//как заполнить массив решите сами

int temp[4];//массив который будет хранить 4 четных элемента
int flag=0;
int j=0;

for(int i=flag;i<10;++i)<br>{
if(mass[i]%2)temp[j]=mass[i];
flag=i;
++j;
}

int Sum=0;
for(int j=0;j<4;++j)<br>{Sum+=temp[j];
cout<<temp[j]<<"\n";<br>}
cout<<Sum;<br>}

(162 баллов)