(ПАСКАЛЬ) Напишите программу, которая по введенным с клавиатуры числам e, f и g будет...

0 голосов
110 просмотров

(ПАСКАЛЬ) Напишите программу, которая по введенным с клавиатуры числам e, f и g будет вычислять значения коэффициентов a, b и c квадратного уравнения по предлагаемым формулам, а также значение дискриминанта D, решать это квадратное уравнение и выдавать результаты его решения.
a= √(|e^2-g| / 3)
b= |e-f/7|^3 - cos g
c= f^3 - g/17,
где дискриминант D=b^2-4*a*c; корни уравнения x1,2= -b+-√D / 2*a
e=2
f= -3
g= -3
a=1.52753; b=1.35442; c=-26.8235; d=165/729; x1=3.77053; x2=-4.65721


Информатика (22 баллов) | 110 просмотров
0

Вы пропустили скобки в формуле для b. Чтоы при указанных значениях e, f, g получилось контрольное значение, должно быть b= |(e-f)/7|^3 - cos g

Дан 1 ответ
0 голосов
Правильный ответ

Var
  a,b,c,d,e,f,g,x1,x2:real;
begin
  Write('Введите значения e,f,g: '); Readln(e,f,g);
  a:=sqrt(abs(sqr(e)-g)/3); Writeln('a= ',a:0:5);
  b:=abs((e-f)/7); b:=b*sqr(b)-cos(g); Writeln('b= ',b:0:5);
  c:=f*sqr(f)-g/17; Writeln('c= ',c:0:5);
  d:=sqr(b)-4*a*c;
  if d<0 then Writeln('Действителных корней нет')<br>  else
    if d=0 then begin
      x1:=(-b-sqrt(d))/(2*a); x2:=x1;
      Writeln('x1=x2= ',x1:0:5)
    end
    else begin
      x1:=(-b-sqrt(d))/(2*a); x2:=(-b+sqrt(d))/(2*a);
      Writeln('x1= ',x1:0:5,', x2= ',x2:0:5)
    end
end.

Тестовое решение:
Введите значения e,f,g: 2 -3 -3
a= 1.52753
b= 1.35442
c= -26.82353
x1= -4.65721, x2= 3.77053


(142k баллов)