дано вещественное число. напишите программу , каторая возводит в квадрат целую часть...

0 голосов
38 просмотров

дано вещественное число. напишите программу , каторая возводит в квадрат целую часть данного числа и выводит на экран монитора результат.

ребяят мне срочно!))


Информатика (49 баллов) | 38 просмотров
Дан 1 ответ
0 голосов

так уж и быть, напишу на Pascal'е

 

var

a: real;

begin

read(a);

a:=Trunc(a); {отбрасывание дробной части}

a:=a*a;

writeln(a);

end.

 

P.S В следующий раз пиши на чём писать программу(а то я обычно пишу на таком языке, которого не знает автор задачи).

(772 баллов)