Напишите программу, которая по данному числу n от 1 до 9 выводит ** экран n флагов....

0 голосов
444 просмотров

Напишите программу, которая по данному числу n от 1 до 9 выводит на экран n флагов. Изображение одного флага имеет размер 4×4 символов, между двумя соседними флагами также имеется пустой (из пробелов) столбец. Разрешается вывести пустой столбец после последнего флага. Внутри каждого флага должен быть записан его номер — число от 1 до n.
входные данные
1
выходные данные
+___
|1 /
|__\
|

Паскаль. Нужно использовать фор.


Информатика (163 баллов) | 444 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var 
 i,n:integer;
begin 
  read(n); 
  for i:=1 to n do   
   write('+___ '); 
  writeln; 
  for i:=1 to n do 
    write('|',i,' / '); 
  writeln; 
  for i:=1 to n do   
   write('|__\ '); 
  writeln; 
 for i:=1 to n do 
    write('|    ');
end.

(242 баллов)