Программирование в Pascal) Надо написать программу. 1.N=20 Определить сумму отрицательных...

0 голосов
60 просмотров

Программирование в Pascal)
Надо написать программу.
1.N=20 Определить сумму отрицательных элементов массива.
2.Сдвинуть элементы массива на одну позицию вправо, последний элемент переместить на первое место.
3.Все положительные элементы исходного массива записать во второй массив, все отрицательные элементы – в третий массив.


Информатика (24 баллов) | 60 просмотров
0

Ща еще напишу

0

Спасибо тебе большое, очень выручаешь))

0

Вроде работают, Это изи, так что обращайся в лс если надо будет)

0

Мне бы вот ещё одно решить)Ввести имя, отчество и фамилию человека (в одну переменную). Определить пол человека (по отчеству).

0

Program A1;vara:string;beginread(a);if copy(a,length(a),1)='ч' then writeln('Муж');if copy(a,length(a),1)='а' then writeln('Жен');end.

0

Я уже сделал ^_^

Дан 1 ответ
0 голосов
Правильный ответ

1. 
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
begin
a:=0;
for i:=1 to n do begin
readln(o[i]);
if o[i]<0 then a:=a+o[i];<br>end;
writeln(a);
end.

2.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
begin
a:=0;
for i:=1 to n do readln(o[i]);
a:=o[n];
for i:=n-1 downto 1 do o[i+1]:=o[i];
o[1]:=a;
for i:=1 to n do  write(' ',o[i],' ');
end.

3.
Program A1;
const n=20;
var
i,a:integer;
O:array[1..n] of integer;
P:array[1..n] of integer;
M:array[1..n] of integer;
begin
for i:=1 to n do begin
readln(o[i]);
if o[i]>0 then p[i]:=o[i];
if o[i]<0 then m[i]:=o[i];<br>end;
for i:=1 to n do write(' ',o[i],' ');
writeln;
for i:=1 to n do
if p[i]<>0 then
write(' ',p[i],' ');
writeln;
for i:=1 to n do  
if m[i]<>0 then
write(' ',m[i],' ');
writeln;
end.

(452 баллов)
0

Спасибо)