Напишите программу, которая вводит координаты двух точек ** числовой оси и выводит...

0 голосов
356 просмотров

Напишите программу, которая вводит координаты двух точек на числовой оси и выводит расстояние между ними.(Программа должна вывести одно число: расстояние между точками с тремя знаками в дробной части.)
совсем не получается решить , помогите пожалуйста



Информатика (76 баллов) | 356 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Program rast;
var x, y, l: real;
begin
  writeln('введите две координаты');
  readln(x, y);
  l:=sqrt(sqr(x)+sqr(y));
  writeln('расстояние ', l:3:2);
end.

(8.6k баллов)
0 голосов

1.{1.Напишите программу, которая вводит два вещественных числа, x и y , и вычисляет значение x^y .(Нужно вывести одно значение – x^y – с тремя знаками в дробной части.)}
  
var x,y,k:real;
begin
 readln(x,y);
 k:=exp(y*ln(x));
 writeln(k:3:3);
end.

(325 баллов)
0

спасибо большое) правда первую уже решила сама
а вторую не знаете как?