Помогите написать программу в паскале

0 голосов
50 просмотров

Помогите написать программу в паскале


image

Информатика (790 баллов) | 50 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var r:integer;
o:string;
begin
writeln('Тест "Приятно ли с вами общаться?"');
writeln('Вы любите больше слушать, чем говорить?');
read(o);
if o='Да' then inc(r);
writeln('Вы всегда можете найти тему для разговора даже с незнакомым человеком?');
read(o);
readln;
readln;
if o='Да' then inc(r);
writeln('Вы всегда внимательно слушаете собеседника?');
read(o);
readln;
if o='Да' then inc(r);
writeln('Любите ли вы давать советы?');
read(o);
readln;
if o='Да' then inc(r);
writeln('Если тема разговора вам не интересна, станете ли вы показывать это собеседнику??');
read(o);
readln;
if o='Да' then inc(r);writeln('Раздражаетесь ли вы, когда вас не слушают?');
read(o);
readln;
if o='Да' then inc(r);
writeln('У вас есть собственное мнение по любому вопросу?');
read(o);
readln;
if o='Да' then inc(r);
writeln('Если тема для разговора вам не знакома, станете ли вы её развивать?');
read(o);
readln;
if o='Да' then inc(r);
writeln('Любите ли вы быть центром внимания?');
read(o);
readln;
if o='Да' then inc(r);
writeln('Есть ли хотя бы три предмета, по которым вы обладаете достаточно прочными знаниями?');
read(o);
readln;
if o='Да' then inc(r);
writeln('Вы хороший оратор?');
read(o);
readln;
if o='Да' then inc(r);
if (r>=1) and (r<=3) then writeln('Трудно сказать, то ли вы молчун, то ли настолько общительны, что вас стараются избегать, общаться с вами не всегда приятно');<br>if (r>=4) and (r<=9) then writeln('Вы, может быть, и не слишком общительны, но почти всегда внимательный и приятный собеседник');<br>if (r>=10) then writeln('Вы, наверное, один из самый приятных собеседников, друзья не могут без вас обойтись');
end.

(1.7k баллов)