Написать программу ** языке Паскаль. Даны три действительные числа. Сложить те из них,...

0 голосов
69 просмотров

Написать программу на языке Паскаль. Даны три действительные числа. Сложить те из них, значения которых не отрицательны.


Информатика (89 баллов) | 69 просмотров
0

program chisl;var a,b,c:integer;beginwrite('Введите a = ' );readln(a);if a>=0 then a:=(a) ;write('Введите b = ' );readln(b);if b>=0 then b:=(b) ;write('Введите c = ' );readln(c);if c>=0 then c:=(c) ;writeln('a );end.

0

довести до умы надо не как не пойму

Дано ответов: 2
0 голосов
Правильный ответ

Program chisl;
var a,b,c,d:integer;
begin
write('Введите a = ' );
readln(a);
if a>=0 then d:=d+a;
write('Введите b = ' );
readln(b);
if b>=0 then d:=d+b;
write('Введите c = ' );
readln(c);
if c>=0 then d:=d+c;
writeln(d);
end.

(1.7k баллов)
0

Например Введите a = 6
Введите b = 4
Введите c = -3
10
Сумма положительных чисел равна

0

program chisl;
var a,b,c,d:integer;
begin
write('Введите a = ' );
readln(a);
if a>=0 then d:=d+a;
write('Введите b = ' );
readln(b);
if b>=0 then d:=d+b;
write('Введите c = ' );
readln(c);
if c>=0 then d:=d+c;
writeln(d);
write('Сумма положительных чисел равна ',d)
end.

0

и 10 стоит впереди предложения Сумма положительных чисел равна , а как сделать так чтобы было после предложения а потом число

0

program chisl;
var a,b,c,d:integer;
begin
write('Введите a = ' );
readln(a);
if a>=0 then d:=d+a;
write('Введите b = ' );
readln(b);
if b>=0 then d:=d+b;
write('Введите c = ' );
readln(c);
if c>=0 then d:=d+c;
write('Сумма положительных чисел равна ')
end.

0

Djn nfr dthytt

0

ВОт так вернее

0

черд

0

program chisl;
var a,b,c,d:integer;
begin
write('Введите a = ' );
readln(a);
if a>=0 then d:=d+a;
write('Введите b = ' );
readln(b);
if b>=0 then d:=d+b;
write('Введите c = ' );
readln(c);
if c>=0 then d:=d+c;
write('Сумма положительных чисел равна ',d)
end.

0

Вот

0

спасибо

0 голосов

Var a, b, c, rez: real;
begin
write('Введите число А: ');
readln(a);
write('Введите число B: ');
readln(b);
write('Введите число C: ');
readln(c);
if (a >= 0) and (b >= 0) and (c >= 0) then rez := a + b + c;
if (a >= 0) and (b >= 0) then rez := a + b;
if (a >= 0) and (c >= 0) then rez := a + c;
if (b >= 0) and (c >= 0) then rez := b + c;
if (a <= 0) and (b <= 0) then rez := c;<br>if (b <= 0) and (c <= 0) then rez := a;<br>if (a <= 0) and (c <= 0) then rez := b;<br>if (a <= 0) and (b <= 0) and (c <= 0) then rez := 0;<br>writeln(rez);
end.

Громоздко, но, думаю, покатит

(2.3k баллов)