"Написать программу,которая вводит массив из N целых чисел и выводит на экран элементы с чётными индексами(индексация начинается с нуля). Протестировать программу на произвольных массивах размерностью 5 и 8 элементов."
Для программы с 8-ми элементным массивом нужно const int n = 5 изменить на const int n = 8
#include
using std::cout;
using std::cin;
using std::endl;
int main()
{
const int n = 5;
int a[n];
cout << "Enter 5 numbers: ";<br>
for(int i = 0; i < n; i++)
{
cin >> a[i];
}
for(int i = 0; i < n; i++)
{
if(i % 2 == 0)
{
cout << a[i] << ' ';<br> }
}
cout << endl;<br>
return 0;
}