Составьте программу, которая формирует массив из 20 случайных целых чисел, каждое из...

0 голосов
40 просмотров

Составьте программу, которая формирует массив из 20 случайных целых чисел, каждое из которых находится в диапазоне от -15 до 15, и выводит на экран вначале исходные, а затем только отрицацельные элементы массива


Информатика (14 баллов) | 40 просмотров
Дан 1 ответ
0 голосов

program z1;

var

     a:array [1..20] of integer;

     i:integer;

begin

for i:= 1 to 20 do

a[i]:=random(30)-15;

for i:= 1 to 20 do

write(a[i]);

writeln; 

 for i:= 1 to 20 do

if a[i]<0</p>

then  write(a[i]);

end.

 

 

 вроде всё правильно, но желательно всё проверить на программе(у меня удалилась), и ОСОБЕННО проверить строку 7(там в скобках точно не знаю там 30 или 31 должно быть)

 

 

 

 

 

 

 

 

(388 баллов)