Составьте программу, по которой ** экран будет выведена вся таблица умножения

0 голосов
137 просмотров

Составьте программу, по которой на экран будет выведена вся таблица умножения


Информатика (111 баллов) | 137 просмотров
Дано ответов: 2
0 голосов
Правильный ответ

Var b,a:integer; 
begin
 for b:=1 to 10 do begin
  for a:=1 to 10 do begin
   writeln(a,'*',b,'=',a*b);
  end;
 end;
end.
получается не в виде таблицы
 а в столбик

(8.6k баллов)
0

спасибо.

0 голосов

// F#
[]
let main argv =
    let generateTable n m =
        Array2D.init n m (fun i j -> (i+1) * (j+1))
    let printMatrix (matrix:int[,]) =
        printf "    "
        for i = 0 to (Array2D.length1 matrix) - 1 do
            printf "%4d " (i+1)
        printf "\n"
        printf "    "
        for i = 0 to (Array2D.length1 matrix) - 1 do
            printf "-----"
        printf "\n"
        for j = 0 to (Array2D.length2 matrix) - 1 do
            printf "%2d |" (j+1)
            for i = 0 to (Array2D.length1 matrix) - 1 do
                printf "%4d " matrix.[i, j]
            printf "\n"
        printf "\n"
    let inputArray = generateTable 10 10
    printMatrix inputArray
    System.Console.ReadKey true |> ignore
    0

(1.4k баллов)
0

тут выводиться таблица

0

спасибо

0

А вот так это делается без новомодных выпендрёжей на старом добром qBASIC

0

CLS
s$ = " "
FOR i = 1 TO 9
s$ = s$ + STR$(i) + " "
NEXT i
PRINT s$
FOR i = 1 TO 9
PRINT USING "###"; i;
FOR j = 1 TO 9
PRINT USING "###"; i * j;
NEXT j
PRINT
NEXT i
END

0

И вывод получается в виде привычной всем таблицы умножения.