Написать программу с помощью цикла с предусловием (while). Вычислить сумму чисел в...

0 голосов
106 просмотров

Написать программу с помощью цикла с предусловием (while).
Вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.


Информатика (420 баллов) | 106 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

// F#
open System
[]
let main argv =
    let mutable sum = 0
    let mutable i = 0
    let array = [19..51]
    while i < array.Length do
        let value = array.Item i
        if 5 % value = 0 then
             sum <- sum + value<br>        i <- i+1<br>    Console.WriteLine sum
    Console.ReadKey true |> ignore
    0

// Pascal (for)
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 0;
  for i:=19 to 51 do
  begin
    if i mod 5 = 0 then
      sum := sum + i;
  end;
  writeln(sum);
end.

// Pascal
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 19;
  while (i <= 51) do<br>  begin
    if i mod 5 = 0 then
      sum := sum + i;
    i := i + 1;
  end;
  writeln(sum);
end.

(1.4k баллов)
0

добавил паскаля, даж много впоимнать не пришлось

0

спасибо тебе огромное!!!

0

ахаха, это цикл с известным количеством повторений, а нужно с предусловием..

0

while tn ybult((

0

while нет нигде((

0

о точно забыл ужо, добавил

0

спасссиииииибо))))))

0

цикл с известным количеством повторений
все ты знаешь, чего ж написать то не можешь?:)

0

ахаха, умные слова, не правда ли?
Что то у меня ничего не получается, если я сама делаю))
а теорию я знаю отлично))

0

еще раз большое спасибо за помощь!