Напишите программу ** паскаль Заполните массив случайными числами в интервале [0,5]....

0 голосов
307 просмотров

Напишите программу на паскаль
Заполните массив случайными числами в интервале [0,5]. Введите число X и найдите все значения равные x


Информатика (122 баллов) | 307 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var  a: array[1..5] of integer; 
       x, i: integer;
begin 
  for i := 1 to 5 do 
   begin   
      a[i] := random(5);
      write(a[i],' ');
   end; 
writeln('Введите x'); 
readln(x); 
for i := 1 to 5 do   
  if a[i] = x then writeln('Иксу равен ', i, '-ый элемент массива');
end.

(932 баллов)