Программа должна вывести введенное число n и одно из слов (** латинице): korov, korova...

0 голосов
195 просмотров

Программа должна вывести введенное число n и одно из слов (на латинице): korov, korova или korovy, например, 1 korova, 2 korovy, 5 korov. Между числом и словом должен стоять ровно один пробел. решить в паскале ABC


Информатика (72 баллов) | 195 просмотров
0

а число n в каком диапазоне?

0

По данному числу n закончите фразу "На лугу пасется..." одним из возможных продолжений: "n коров", "n корова", "n коровы", правильно склоняя слово "корова".Входные данныеДано число n (n<100).Выходные данныеПрограмма должна вывести введенное число n и одно из слов (на латинице): korov, korova или korovy, например, 1 korova, 2 korovy, 5 korov. Между числом и словом должен стоять ровно один пробел.вот вся задача

Дан 1 ответ
0 голосов
Правильный ответ

Begin
var a := ReadInteger;
var c : string;
Assert(a >= 1);
Assert(a <= 99);<br> case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: c := 'korova';
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: c := 'korovy';
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..100: c := 'korov';
end;
Writeln('На лугу пасется ', a, ' ', c);
end.

(470 баллов)
0

спасибо