Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено...

0 голосов
342 просмотров

Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. В конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0).


Информатика (14 баллов) | 342 просмотров
Дано ответов: 2
0 голосов

Program N94780249;
const
  s: longint = 0;
var
  x: longint;
  t: string;
  e: integer;
begin
  writeln('Вводите целые числа (0 - окончание ввода) : ');
  repeat
    repeat
      write('> ');
      readln(t);
      val(t, x, e);
      if e <> 0 then
        writeln('Ошибка! Повторите ввод. ')
    until e = 0;
    s += x
  until x = 0;
  if s = 0 then
    writeln('Числа не вводились. ')
  else
    writeln('Сумма введённых чисел = ', s, #10);
  write('Для завершения работы нажмите Enter...');
  readln
end.

(130 баллов)
0

Эм? В условии про сумму введенных чисел ничего не говорилось.

0

и сразу вы указываете s как константу, и в ходе программы хотите ее изменять..

0

перед тем как воровать чье-то решение, хотя бы удостоверились, что оно подходит под данное условие задачи -_-

0 голосов

Решение в прикрепленном файле :) 

(5.1k баллов)
0

можно вопрос? а почему вы min и max приравниваете к a?

0

а что не так-то?

0

вот же ш.. немного подправить надо решение, оплашался я

0

изменил, теперь покатит

0

хм.. а если ввести просто 0 то он выдаст max=1 min=1

0

Ну вообще выводить будет 0.. но и это я поправил.