Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных...

0 голосов
63 просмотров

Написать программу в Паскале.
По заданному числу N определите знак числа.
Формат входных данных:
Во входном файле input.txt записано одно целое число N (-10000<=N<=10000)<br> Формат выходных данных:
если заданное число положительное, то в выходной файл output. txt выведите квадрат этого числа. Если заданное число отрицательное, то вывелите модуль этого числа. Если же заданное число - нуль , то и вывести надо нуль.
Примеры:
input.txt output.txt
5 25
-5 5
0 0


Информатика (15.4k баллов) | 63 просмотров
Дан 1 ответ
0 голосов
Это если алгоритм выполнить дословно:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, 'input.txt'); Reset(f1);
  Assign(f2, 'output.txt'); Rewrite(f2);
  Readln(f1, n);
  if n < 0 then Writeln(f2, abs(n))
  else
  if n = 0 then Writeln(f2, 0)
  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.

А это, если учесть, что модуль нуля равен нулю:

var
  f1, f2: Text;
  n: integer;

begin
  Assign(f1, 'input.txt'); Reset(f1);
  Assign(f2, 'output.txt'); Rewrite(f2);
  Readln(f1, n);
  if n <= 0 then Writeln(f2, abs(n))<br>  else Writeln(f2, sqr(n));
  Close(f1); Close(f2)
end.


(142k баллов)
0

Спасибо!))))))

0

Пожалуйста. Но достаточно кнопочки со звездочками))

0

)))) Пусть будет и то и то.

0

Потом модераторы все равно комментарии отрезают