Помогите написать программу ** языке Паскаль) В прямоугольник со сторонами a и b вписан...

0 голосов
28 просмотров

Помогите написать программу на языке Паскаль)
В прямоугольник со сторонами a и b вписан круг. Найти длину окружности.


Информатика (22 баллов) | 28 просмотров
Дан 1 ответ
0 голосов

Если ты имел ввиду описанную около пр-ка окружность то вот

program dlinap;
uses crt;
var a,b,diam,dlina : real;
const pi=3.14;
begin
write('Чему равна длина и ширина пр-ка?');
Readln(a,b);
diam:=sqrt(sqr(a)+sqr(b));
dlina:=pi*diam;
Writeln('Длина окружности равна ',dlina);
end.

(654 баллов)