написать программу с организацией ввода-вывода с помощью текстовых файлов. В каждой...

0 голосов
48 просмотров

написать программу с организацией ввода-вывода с помощью текстовых файлов.

В каждой задаче задается квадратная матрица NxN. Программа должна осуществлять ввод и печать исходной матрицы и возможно, дополнительных данных, произвести необходимые действия и напечатать результаты.

Найти в каждом четном по номеру столбце матрицы максимальный элемент и вычислить произведение этих элементов.


Информатика (69 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

var a:array[1..10,1..10]of integer;
i,j,k,s:integer;
begin
for i:=1 to 10 do for j:=1 to 10 do a[i,j]:=random(9)+1;
for i:=1 to 10 do begin for j:=1 to 10 do write(a[i,j],' '); if j=10 then writeln; end;
s:=1;
for i:=2 to 10 do begin k:=a[i,1];
for j:=2 to 10 do begin
if i mod 2 = 0 then if a[i,j]>k then k:=a[i,j];
if (j=10) and (i mod 2=0) then s:=s*k;
end;
end;

writeln(s);
end.

(9.9k баллов)