Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор...

0 голосов
49 просмотров

Ребят, помоги в паскале. напишите программу которая вводит с клавиатуры числа до тех пор пока не будет введено число 0. В конце работы программы на экран выводится сумма и произведение введенных чисел.


Информатика (12 баллов) | 49 просмотров
Дан 1 ответ
0 голосов

Var a,s,p:integer;
begin
p:=1;
read(a);
if(a=0) then p:=0;
while(a<>0)do begin
  s+=a;
  p*=a;
  read(a);  end;
writeln(s, ' ', p);
end.

(4.7k баллов)