Напишите программу решения задачи ** языке Паскаль: Даны два целых двузначных числа....

0 голосов
61 просмотров

Напишите программу решения задачи на языке Паскаль: Даны два целых двузначных числа. Переставить местами цифры наибольшего из них. Если полученное число останется наибольшим вывести «YES», в противоположном случае вывести «NO».


Информатика (15 баллов) | 61 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  a,b,max,min:integer;
begin
  Write('Введите два целых двухзначных числа: '); Readln(a,b);
  if a>b then begin max:=a; min:=b end
  else begin max:=b; min:=a end;
  if (10*(max mod 10)+(max div 10))>min then Writeln('YES')
  else Writeln('NO')
end.

(142k баллов)