ПОМОГИТЕ ПОЖАЛУЙСТА!!! СРОЧНО НАДО!! Написать программу (** PascalABC.Net) создающую файл...

0 голосов
58 просмотров

ПОМОГИТЕ ПОЖАЛУЙСТА!!! СРОЧНО НАДО!! Написать программу (на PascalABC.Net) создающую файл содержащий сведения о книгах.Сведения о каждой из книг это фамилия автора,название и год издания.Даннная программа обращается к модулю в которой подсчитываются количество книг изданнных до 2000 года


Информатика (122 баллов) | 58 просмотров
Дан 1 ответ
0 голосов

Type
  tBook = record
    author: string[20];
    title: string[30];
    year: integer
  end;

var
  f1: file of tBook;

function k2000(): integer;
{ файл должен быт открыт на чтение }
var
  k: integer;
  book: tBook;
begin
  while not Eof(f1) do
  begin
    Read(f1, book);
    if book.year < 2000 then k := k + 1
  end;
  k2000 := k
end;

var
  B: tbook;

begin
  Assign(f1, 'books.000');
  Rewrite(f1);
  Writeln('Для книги вводите в трех строках: автор, название, год издания');
  Writeln('Введите * для завершения ввода');
  repeat
    Readln(B.author);
    if B.author[1] <> '*' then
    begin
      Readln(B.title); Readln(B.year); Write(f1, B)
    end
  until B.author[1] = '*';
  Close(f1);
  Write('Количество книг, изданных до 2000г равно ');
  Reset(f1);
  Writeln(k2000);
  Close(f1)
end.

Пример диалога с программой:
Для книги вводите в трех строках: автор, название, год издания
Введите * для завершения ввода
Александр Грин
Бегущая по волнам
1984
Эдгар Аллан По
Золотой жук
2002
Луи Буссенар
Капитан Сорви-голова
1997
Гарри Гаррисон
Крыса из нержавеющей стали
2007
А. и Б. Стругацкие
Сказка о Тройке
1974
*
Количество книг, изданных до 2000г равно 3



(142k баллов)