Program sro3_2; var A,B,C:array [1..20] of integer; n,k,l,i:integer; begin ...

0 голосов
135 просмотров

Program sro3_2;
var
A,B,C:array [1..20] of integer;
n,k,l,i:integer;
begin

writeln('|||Входные данные задачи|||');
write('Введите количество элементов:');
readln(n);
writeln('Массив А:');
for i:=1 to n do;
read(A[i]);
k:=1;
l:=1;
for i:=1 to N do
if i mod 2=0 then begin k:=k+1;
B[k]:=A[i];

end
else l:=l+1;
C[l]:=A[i];

writeln('Массив B с четными элементами:',b[k]);
read(b[k]);
writeln('Массив C с нечетными элементами:',c[l]);
read(c[l]);
writeln;
writeln;
end.
НЕ МОГУ НАЙТИ ОШИБКУ ИСПРАВЬТЕ ПЛИИИЗЗЗЗ!!!!!


Информатика (24 баллов) | 135 просмотров
0

алоооо помогите

Дан 1 ответ
0 голосов

Var
A,B,C:array [1..20] of integer;
n,k,l,i:integer;
begin 
writeln('|||Входные данные задачи|||');
write('Введите количество элементов:');
readln(n);
writeln('Массив А:');
for i:=1 to n do
Begin
read(A[i]); 
if a[i] mod 2=0 then
 begin k:=k+1;
B[k]:=A[i];
end
else
l:=l+1;
C[l]:=A[i];
End;
writeln('Массив B с четными элементами:');
for i:=1 to k do
write(b[i],'  ');
writeln;
writeln('Массив C с нечетными элементами:');
for i:=1 to l do
write(c[i],'  ');
end.

(34 баллов)
0

ответ не вышел