Дано трехзначное число.Найти сумму цифр числа.(Написать программу ** языке Паскаль)

0 голосов
53 просмотров

Дано трехзначное число.Найти сумму цифр числа.(Написать программу на языке Паскаль)


Информатика (402 баллов) | 53 просмотров
Дано ответов: 2
0 голосов

Люблю работать в Паскале)

(1.1k баллов)
0 голосов

Program chisla;
uses crt;
var a,b,c,d : integer;
begin
Writeln('Введите трехзначное число: ');
Readln(a);
if (a<100) or (a>999) then writeln('Введено не трехзначное число')
else
begin
b:=a div 100;
c:=(a-(b*100)) div 10;
d:=a-(b*100)-(c*10);
Writeln('Сумма цифр этого числа равна ',b+c+d);
end
end.

(654 баллов)