Написать программу в Pascal по циклам: Ежедневно ученик делает в диктанте разное кол-во...

0 голосов
46 просмотров

Написать программу в Pascal по циклам:
Ежедневно ученик делает в диктанте разное кол-во ошибок.За сколько дней кол-во ошибок достигнет числа q?(Написать программу с циклом while)


Информатика (738 баллов) | 46 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Program gt;
var q,k,a,s:integer;
begin
writeln('Задайте q');
readln(q);
k:=-1;s:=0;
while q>s do
begin
k:=k+1;
read(a);
s:=s+a;
end;
writeln(k);
end.

(6.6k баллов)