составить программу ** языке Паскаль по формуле:

0 голосов
32 просмотров
составить программу на языке Паскаль по формуле:


image

Информатика (45 баллов) | 32 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
  S, p, a,b,c : Real;
begin
  writeln('Введите a: ');
  readln(a);
  writeln('Введите b: ');     
  readln(b);     
  writeln('Введите c: ');
  readln(c);     
  // C не может быть = 0     
  if c = 0 then  
     writeln('C не может быть равен 0') 
   else
   begin       
   //Вычисляем P:    
   p := (a+b+c)/c;        
   //Вычисляем корень:    
   S := sqrt( p*(p-a)*(p-b)*(p-c) );
   // Результат:
   writeln('P = ', p);    
   writeln('S = ', S);  
   end;    
end.

(136 баллов)