Решить ** языке Питон (в крайнем случае ** Паскале) По данным двум натуральным числам A и...

0 голосов
140 просмотров

Решить на языке Питон (в крайнем случае на Паскале) По данным двум натуральным числам A и B (A≤B) выведите все чётные числа на отрезке от A до B. В этой задаче нельзя использовать инструкцию if.
Пример: Входные данные: 1 10 Выходные данные: 2 4 6 8 10


Информатика (102 баллов) | 140 просмотров
0

И кто решил, что он перспективный? Ваш преподаватель информатики? Поинтересуйтесь историей развития языков программирования - и Вы удивитесь, сколько "перспективных", казалось бы, языков, всерьез принимаемых большими и авторитетными организациями, оказалось достоянием истории!

0

Alviko. об этом можно долго спорить Паскаль отживает своё, используется в основном для обучения Питон удобен для олимпиад, хотя есть минусы, а для организаций и программирования годятся другие языки У каждого языка определенные области применения Я начала с изучения паскаль, питон, 1С

0

Дожили! Изучаем в школе язык "для обучения", а дополнительно - "для олимпиад". А в реальной жизни "для организаций и программирования" - некие "другие языки". Т.е. школьную программу по-вашему составили полные дебилы, тратя время и забивая детям головы изучением непонятно чего, а закончив школу, это все надо прочно забыть.

0

Что до 1С - это вообще конкретный пакте программ для бухгалтерии, о нем какой смысл говорить вообще? Давайте еще говорить про языки расширения для AutoCAD, Adobe Photoshop и других пакетов..

0

*пакет

0

Так и получается. что изучаем один язык. потом другой, третий, в зависимости от того для чего язык нужен А школьная программа стандартная и не учитывает все нюансы Повторюсь- в разных областях используют разные языки Какой язык в будущем пригодиться мне, я пока не знаю

0

1С можно использовать для решения задач, необязательно использовать готовые бухгалтерские шаблоны" Хотя- 1С- неудобный и вообще- г...

0

Вот поэтому и надо в школах не УЧИТЬ ЯЗЫК ПРОГРАММИРОВАНИЯ, а УЧИТЬСЯ ПРОГРАММИРОВАНИЮ.

0

Alviko ,посоветуйте. какой язык выбрать Для олимпиадного программирования надо два языка 1-Паскаль. 2- питон или С++ Напишите в личку, а то здесь слишком длинная дискуссия получилась

0

Лучший язык это всегда тот, к которому Вы привыкли...

Дан 1 ответ
0 голосов
Правильный ответ

A=int(input())
B=int(input())
for i in range(A, B+1,+2):
    c=i%2+i
    for c in range(A,B):
        print(c) 

(78 баллов)
0

Ой, простите, сейчас исправлю.

0

А он не будет выводить переменную с из первого цикла, а потом со второго?

0

В этом и проблема. Здесь изюминка задания в том, как мне кажется, что нужно убрать лишнее значение "с", которое больше В в том случае, когда А и В - нечетные. Можете пока подумать сами как от него избавиться)))

0

Вот думаю... ( с if было бы проще)

0

Исправлено, проблема решена исправлением 1 цикла. Просто сделано так, чтобы цикл начинался с четного числа.

0

WarWara98 абсолютно верно, я так же решила и уже проверила в тестирующей системе, мы с тобой МАЛАДЦЫ!!!