Написать программу в паскале "Ввести номер месяца и номер дня, вывести число дней,...

0 голосов
59 просмотров

Написать программу в паскале "Ввести номер месяца и номер дня, вывести число дней, оставшихся до Нового года и на каждый месяц поздравление!"

Напишите хотя бы программу для вывода числа дней, оставшихся до Нового года, а то я такое не умею. Хотя бы!!!! =(


Информатика (53 баллов) | 59 просмотров
0

Поздравление какое?

0

Незнаю что за поздравление, этот пункт можно опустить.

Дан 1 ответ
0 голосов
Правильный ответ

Program go;
var x,y,z,n:real;
begin
write('Введите сегодняшнее число: '); 
readln(x);
write('Введите номер сегодняшнего месяца: '); 
readln(y);
 begin 
if y=1 
then n:=365-x 
 else; 
if y=2 
 then n:=365-31-x 
 else; 
if y=3 
then n:=365-31-28-x 
 else; 
if y=4 
 then n:=365-31-28-31-x 
 else; 
if y=5 
 then n:=365-31-28-31-30-x 
 else; 
if y=6 
 then n:=365-31-28-31-30-31-x 
  else; 
if y=7 
then n:=365-31-28-31-30-31-30-x 
  else; 
if y=8 
 then n:=365-31-28-31-30-31-30-31-x 
 else; 
if y=9 
 then n:=365-31-28-31-30-31-30-31-31-x 
  else; 
if y=10 
then n:=365-31-28-31-30-31-30-31-31-30-x 
 else; 
if y=11 
then n:=365-31-28-31-30-31-30-31-31-30-31-x 
 else; 
if y=12 
 then n:=365-31-28-31-30-31-30-31-31-30-31-30-x   
else;
 end; 
 writeln ('До Нового года осталось:  ',n);
end.

(1.2k баллов)