20 mod x = 20 div x Найти x через Паскаль(составить программу)! ответ:9,19

0 голосов
63 просмотров

20 mod x = 20 div x Найти x через Паскаль(составить программу)! ответ:9,19


Информатика (154 баллов) | 63 просмотров
Дан 1 ответ
0 голосов

Program eq;
uses crt;
var x: integer;
begin
for x:=1 to 20 do if (20 mod x)=(20 div x) then writeln(x);
readln;
end.

Пояснение, почему значение x взято  до 20. Дело в том, что после 20 результат ф-ции 20 mod x всегда будет равен 20, а ф-ции 20 div x всегда будет равен 0.

(7.2k баллов)
0

ох спасибо, я почти то же самое создал, только не учёл одну мелочь

0

А какую именно?

0

(20 mod x)=(20 div x) и да там ридлн в конце не нужен и юзез в начале

0

А это по привычке с досовского паскаля )

0

аа понятно